Degradation in Screening API

Incident Report for FOCAL Luna

Resolved

This incident has been resolved and all services operating normally.
Posted Oct 15, 2025 - 15:28 GMT+03:00

Update

We are continuing to work on a fix for this issue.
Posted Oct 15, 2025 - 15:27 GMT+03:00

Identified

We have identified an issue
Posted Oct 15, 2025 - 15:27 GMT+03:00

Investigating

We are currently investigating this issue.
Posted Oct 15, 2025 - 14:51 GMT+03:00
This incident affected: FOCAL AML.