This incident has been resolved and all services operating normally.
Posted Sep 24, 2025 - 18:05 GMT+03:00
Update
We have identified the issue related with our cloud provider in KSA (Jeddah). We are working with them for a solution. Will update here as we have more information
Posted Sep 24, 2025 - 17:40 GMT+03:00
Investigating
We are investigating a degradation of the screening service. Will update here as we have more information